iCloud, App Store, iTunes and Facetime fix Hackintosh Lion 10.7.2
Technology

iCloud, App Store, iTunes and Facetime fix Hackintosh Lion 10.7.2

February 17, 2012

I’m upgrading to Lion OS specifically because of this feature- the iCloud. So I was quite frustrated when iCloud “told” me this when I tried to login after upgrading to 10.7.2 :

Your Apple ID is valid but is not an iCloud account

The same thing happens when I tried to log in to my itunes or app store accounts. Denied. Or it was not recognized by Apple or some other error messages.

I did cross check my itunes and app store id on my IOS 5 devices’s iCloud and they are all working. So I figured out this must be something related to hackintosh upgrades.

I did find quite a number of “fix” but they all didn’t work for my hackintosh build. The first two “fix” I tried crashed my hackintosh. I must warn you though that this may not necessarily work for you, or crash your hackintosh (slim chance) or if you have a hackintosh with a raid volume, it may also crash or would not boot at all. But personally, I find this the simpliest and less drastic way of fixing that icloud bug. And it worked!

  1. Download EFI Studio and open it up.
  2. In the dropdown menu for devices, create a device string for your on board LAN.
  3. Paste that string to your org.chamelon.com.plist
  4. I deleted the “ethernetbuiltin” string.
  5. Reboot.
Here is part of an example of your org.chamelon.com.plist
<key>ethernetbuiltin</key>
<string>no</string>
<key>device-properties</key>
<string>paste the string here</string>
Now you have a working Icloud, itunes, facetime account!. Enjoy!
(Note: Please comment below if this didn’t work for your hackintosh build)

 

0

Follow Remo on

Comments (8)

  • 1.Download EFI Studio and open it up.
    2.In the dropdown menu for devices, create a device string for your on board LAN.
    can you upload the image of two first step please

    anh7
  • Ace. Worked for me on 10.7.4 – things were getting a little depressing before I found this post.

    Lemon
  • Hi,

    i’m on 10.7.4 and have the iCloud issue. Tried the SMBios fix, but that didn’t work.
    Tried your fix, but no positive result either.
    This is my org.chameleon.boot.plist:

    EthernetBuiltIn
    no
    Graphics Mode
    1280x1024x32
    GraphicsEnabler
    Yes
    Instant Menu
    Yes
    Kernel
    /mach_kernel_atom_32
    Legacy Logo
    Yes
    PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)
    0x01
    SMBIOSdefaults
    No
    Theme
    Apple Default

    Any help would be great.

    Marijn

    Marijn
  • @Alex, if you have a fast and reliable WIFI connection, applying this step will be almost the same as updating thru wired connection. But if you have a hackintosh build, updating thru wifi ITUNes using this step will not work, or even crash your hackintosh at least in my experience…

    Remo
  • I only have wifi. Will it works?

    Alex
  • I tried everything but this worked. You are a genius.

    Virgil
  • THANK YOU! Oh my godless earth, this had me stuffed. And you just saved me. That is AWESOME!
    Thanks again!!
    (Lion 10.7.2 – Gigabyte P-55A-UD5, Chameleon 2 VS 1627)

    ArctiX
  • Leave a Reply

    Your email address will not be published. Required fields are marked *